msdeploy


MsDeploy.exe ERROR_FILE_IN_USE Error - Octopus Deploy


I am trying to create nuget packages on every builds with Nugetter in VS 2013 and TFS 2013.
Everything is fine. I am creating the packages and putting to a fixed location.
and getting these packeges with Octopus.
On Octopus I have environments and projects. And I can create Releases.
But when I wanted to deploy releases to an environment I am getting the below error.
I am stuck! What can I do for this? Any help?
Error Code: ERROR_FILE_IN_USE
Error 17:58:30
More Information: The file 'Website.zip' is in use. Learn more at: http://go.microsoft.com/fwlink/?LinkId=221672#ERROR_FILE_IN_USE.
Error 17:58:30
Error: The process cannot access '[SomePath]\WebSites\test.octopus.com\Debug\Website.zip' because it is being used by another process.
Error 17:58:30
at Microsoft.Web.Deployment.NativeMethods.RaiseIOExceptionFromErrorCode(Win32ErrorCode errorCode, String maybeFullPath)
Error 17:58:30
at Microsoft.Web.Deployment.FilePathProviderBase.Delete(Boolean whatIf)
Error 17:58:30
Error count: 1.
When I've seen this error in the past it could be one of several things:
First, make sure the file isn't getting marked as read-only.
Next, from time-to-time I have to stop the IIS application pools before copying files to the destination. Then restart when the copy is finished.
Finally, Could some virus scanner be locking the file while you're trying to access it?

Related Links

MSDeploy Parameter
msdeploy Parameters.xml deploy cannot set a value on node type 'Element'
How to make Web Deploy (msdeploy) deploy in a different folder?
How do you add DateTime to MSDeployDeclareParameters
How do you include build outputs as additional files using web deploy (MSDEPLOY)?
MsDeploy.exe ERROR_FILE_IN_USE Error - Octopus Deploy
Web Deploy Package - setParameter for web.config with complex XML
msdeploy: deploy reference of reference
use msdeploy to install a zip-package on a remote computer from commandline
Null ref from inside WebDeploy
How to set destination website on MSDeploy.exe command line
msdeploy could not authorize when user is local admin
WebDeploy 3.0 RunCommand executes too soon via WebDeploy agent
Visual Studio 2013 Web Deploy fails
Set computerName using an MSDeploy parameter
Can I reference an MSDeploy parameter value in a manifest file?

Categories

HOME
google-chrome
user-interface
blast
haproxy
activemq
dronekit-python
mirc
hyperledger
graphql-js
telegraf
responsive-design
timber
eddystone
clickable-image
heuristics
cqrs
sap-fiori
cname
sslhandshakeexception
squirrel-sql
webstore
dma
home
wsf
jitsi
hdl
liferay-6.2
software-packaging
cellular-network
oracleforms
ccavenue
sales
autodesk-model-derivative
progid
mapnik
delayed-job
android-collapsingtoolbar
advanced-filter
xmlunit
db2-luw
netstat
aurelia-cli
telephonymanager
windows-store
notesview
code-push
dredd
sony-future-lab-n
brightscript
jgrapht
htmlspecialchars
dtd
dmarc
between
frame-grab
mathnet
jemdoc
persistent-object-store
wikimedia-commons
myfaces
deeplink
godeps
360-degrees
green-threads
rfc5545
r.java-file
tidyr
findersync
pass-by-value
dos2unix
dmake
berkeley-db-xml
oracle-adf-mobile
libgcc
box2dweb
distributed-r
windows-messages
mfmessagecomposeview
redpitaya
autonumber
visual-c++-2005
jquery-transit
acceptance-testing
rikulo
dibs
proc-open
arrow
image-formats
mvcrecaptcha
expression-web
haiku
rtd
suphp
pinax
tabbarcontroller
fxruby
database-cloning
tso
icon-language
prism-2

Resources

Mobile Apps Dev
Database Users
javascript
java
csharp
php
android
MS Developer
developer works
python
ios
c
html
jquery
RDBMS discuss
Cloud Virtualization
Database Dev&Adm
javascript
java
csharp
php
python
android
jquery
ruby
ios
html
Mobile App
Mobile App
Mobile App