msdeploy


msdeploy and runCommand results in vague “Access is denied” error


I have a preexisting deployment process which successfully deploys a site to its staging environment. Attempting the same process against a new production environment is failing at the point where we try to invoke msdeploy's "runCommand" option.
We're using pstrami, which ultimately uses msdeploy twice. msdeploy successfully copies files to the target machine. pstrami then tries to use msdeploy a second time, this time to use "runCommand" on a bat file that should actually install everything under IIS.
The first use of msdeploy works, copying the files. Therefore, the credentials we're working with are correct.
The second use of msdeploy outputs the following:
Info: Updating runCommand (bootstrap.bat).
Warning: Access is denied.
It appears that bootstrap.bat is not actually reached. It is unclear who is being denied access to what. I suspect that the user is not allowed to perform "runCommand", but advice about runCommand online is inconsistent and has not revealed anything different between my staging and production machines.
What should it take for msdeploy 'runCommand' to be granted access?
MSDeploy supports configuring permissions on a per-provider basis, so your hosting provider may have disabled it. It might be worth checking with them.

Related Links

Msbuild packaging Issue
Is it possible to modify web.config of existing site using MSDeploy?
Deploying nested bin folders using MSDeploy
Web Deployment Issue Using Windows Azure Accelerator For WebRoles
Ignore file attributes with MSDeploy?
What exactly is the Auto Provider in Web Deploy (msdeploy.exe)
psake calling msdeploy.cmd with parameter containing an ampersand
MSdeploy : Web transformation files and parameterization mutually exclusive?
Specify different path for provider iisApp when creating package with msdeploy
msdeploy v2 doesn't work with vs2010's packages
Large files with msdeploy
MSDeploy preserve site name and IP address on Destination
MSDeploy to IIS6 via wmsvc
MSDEPLOY access issue on Windows 2003 and IIS6
Deploy from Visual Studio 2010 stopped working after upgrade to Web Deployment Tool 2.1
Web Deploy script error - msdeploy.exe is not found on this machine

Categories

HOME
hpoo
shinyapps
apk
informatica
celery
implicit-conversion
dji-sdk
roku
swarm
cqrs
fullcalendar-scheduler
jquery-select2-4
jodatime
webstore
distributed-computing
squid
hidden
google-sites
robolectric
deepfreeze
bazaar
adobe-illustrator
gollum-wiki
restier
jstree
web-config-transform
high-availability
python-appium
basex
openbr
audit
toad
cucumber-junit
bean-validation
love2d
cartopy
cloudera-quickstart-vm
mars-simulator
get-event-store
hdiv
google-prediction
docker-ucp
realstudio
windows-media-player
cyanogenmod
knockout-2.0
case-when
polymaps
mpmovieplayercontroller
kendo-treeview
rustdoc
oid
annotatorjs
okio
tablespace
nsdata
oci
apache-pig-grunt
sharepoint-apps
ajax4jsf
android-mapview
directx-9
mixins
featuretoggle
componentart
mutators
baseadapter
mod-auth-openidc
kognitio-wx2
lmax
two.js
thruway
jchartfx
cloo
strcmp
colon
google-code-prettify
firebird1.5
fitch-proofs
n-queens
groovy-console
digiflow
raw-data
subtext
rtti
ning
synthesizer

Resources

Database Users
RDBMS discuss
Database Dev&Adm
javascript
java
csharp
php
android
javascript
java
csharp
php
python
android
jquery
ruby
ios
html
Mobile App
Mobile App
Mobile App